[MOD] Faction War/Economy Enhancer v4.32

The place to discuss scripting and game modifications for X4: Foundations.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Rastuasi
Posts: 76
Joined: Mon, 1. Oct 18, 16:28
x4

Re: [MOD] Faction War/Economy Enhancer v4.31

Post by Rastuasi » Sun, 3. Nov 19, 20:54

CV issue?

Mysterial
Posts: 319
Joined: Wed, 6. Nov 02, 21:31
x4

Re: [MOD] Faction War/Economy Enhancer v4.31

Post by Mysterial » Sun, 3. Nov 19, 21:01

Some CVs don't have enough builder drones and whatever they did in HF1 made it matter. So the build times for station modules are wildly inconsistent. Sometimes it's like before, sometimes it's 2x or worse.

Kyle Baxter
Posts: 6
Joined: Sat, 22. Dec 18, 01:36
x4

Re: [MOD] Faction War/Economy Enhancer v4.31

Post by Kyle Baxter » Thu, 7. Nov 19, 22:03

Hey,

I'm using this mod with all 4 modules alongside Variety and Rebalance Overhaul. My problem is that my fresh 2.6 Universe with those two mods result in broken Kha'ak raiding fleets. I've got a system with a Station in it that spawns those raiding fleets. The ships don't move and i can't attack them or order my ships to attack those. When i try to shot one with my main weapons shoots through and it seems like they can't target the ship properly. Only one ship type is affected and the name is Raiding Party Forager. The system is full with unmoving ships of this type. I already asked the question in the the VRO thread, but i thought i should do it here too. What could cause this? Is there a conflict between the two mods? Did something change in 2.6 that broke the Kha'ak or does the War Module changes the Faction AI and breaks a part?

Mysterial
Posts: 319
Joined: Wed, 6. Nov 02, 21:31
x4

Re: [MOD] Faction War/Economy Enhancer v4.31

Post by Mysterial » Fri, 8. Nov 19, 16:47

I can't see how anything I've done could cause that, but in any case I loaded up a savegame from when I was testing the current version and checked the Kha'ak Installation/spawn zone and there weren't any ghost ships there. Sorry, I don't know what to tell you.

Kyle Baxter
Posts: 6
Joined: Sat, 22. Dec 18, 01:36
x4

Re: [MOD] Faction War/Economy Enhancer v4.31

Post by Kyle Baxter » Fri, 8. Nov 19, 18:33

That is odd, Shuulo the Author of VRO has the same problem with the raiding parties. So I'm at least not alone with my problem. :) He will check later if his mod is messing with something. Right now I'm just ignoring the Kha'ak. I just wanted to tell you both that maybe something is broken. Maybe even the Patch 2.6 is faulty who knows.

Edit: The culprit was found, it was the VRO mod. A line was commented out. By the way, i totally forgot to say thank you for this great mod!

Post Reply

Return to “X4: Foundations - Scripts and Modding”